{{ product.name }}

Hell Yeah! Virtual Rabbit Missions

DRM

$5.49

$5.49

-{{product.discount}}%

Hell Yeah! Virtual Rabbit Missions

$5.49

$5.49

-{{product.discount}}%

50 new missions, adding more than 3 hours of gameplay, to be played in a brand new Virtual Reality world!

Read full description

Deals

Game description

You thought it was over? Nothing is over!! The Virtual Rabbit Missions will test your shooting and speed-running skills in 50 exciting new challenges. Taking place in a brand new Virtual Reality level, these challenges are spread across 3 difficulty settings and add more than 3 hours of gameplay. Only the mightiest rabbit can survive!

  • 74

  • 0

  • Rating
Publisher:
SEGA
Developer:
Arkedo Studios
Genres:
Adventure
Source:
SEGA
Released:
Wednesday, October 24, 2012
Modes:
Languages:
English, French, German, Italian, Spanish
  • OS: Windows XP/Vista/Win7
  • Processor: Intel Core 2 DUO @ 2.4 GHz/Athlon 64 X2 4200+ & above
  • Memory: 1 GB (2 GB on Vista)
  • Graphics: a DirectX 10 compatible graphic card with at least 512 MB
  • DirectXÆ: DirectX 9c (10 on Vista)
  • Hard Drive: 6 GB Free
  • Sound: DirectX Compatible

More like this

Reviews for Hell Yeah! Virtual Rabbit Missions

Our users have spoken

74
Overall score based on 1 reviews

74
New Challenges!

I like a lot this game but it was a bit easy to beat, now with the Virtual Rabbit Missions DLC you can have 50 challenges with a virtual reality scene, most of them are really hard and they have three difficulty settings, if you buy this pack you will have about 3 hours more of gameplay even if you are a very good player. I think this game is a little gem and the developers deserve more support, if you like the game but you need more from this rabbit, this DLC for the game is really worth it.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away
Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required