{{ product.name }}

They Came From The Skies

DRM

$4.95

$4.57

-{{product.discount}}%

WANTED
WANT IT

Community content

They Came From The Skies

$4.95

$4.57

-{{product.discount}}%

$3.99

Associated Products

See All
See Less

Deals

Game description

Planet Earth is under attack! What started as one UFO sighting has turned into a full-scale alien invasion. Only you and your squadron of 1960’s classic aircraft stand in the way of the annihilation of the human race. Take no prisoners; this is a fight to the death!

  • Twenty huge and varied missions with hordes of enemies to destroy
  • Fly fighter jets, attack bombers and captured alien flying saucers
  • Manage aircraft upgrades and repairs to gain the upper hand
  • Destroy alien mother ships, flying saucers, drop ships and infected human military hardware!
Game info
  • 40

  • 0

  • Rating
Publisher:
Midas Interactive Entertainment
Developer:
Midas Interactive Entertainment
Genres:
Source:
Midas Interactive Entertainment
Released:
Friday, May 7, 2010
Modes:
Languages:
Headset:
{{vrNames}}
Customer notes
Minimum Requirements
  • Windows Vista
  • Processor: Pentium 4 1.5 GHz
  • DirectX 9.0
  • 256 MB RAM
  • Video Card: SVGA 64MB Directx 9.0
  • Sound Card
Recommended Requirements
Legal

More like this

User score

40
Overall score based on 1 reviews Leave a review

Reviews for They Came From The Skies

40
They came from the skies, but crashed down...

The first thing you'll notice in this game is the disturbingly awful graphics and the mediocre gameplay. Your goal is to defend earth and the entire human race, by trying to fight off an alien invasion. Although you can upgrade your ships and choose from different aircrafts, the game doesn't quite manage to hold on the thrill. Not one of the best aviation games.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away

Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required