{{ product.name }}

South Park: The Stick of Truth - Samurai Spaceman Pack

DRM

$1.99

$1.79

-{{product.discount}}%

WANTED
WANT IT

Community content

South Park: The Stick of Truth - Samurai Spaceman Pack

$1.99

$1.79

-{{product.discount}}%

$1.71

Samurai Spaceman pack includes: Superhero Costume: Buffs at Start of Combat, Samurai Costume: Buffs when you Defeat an Enemy and Spaceman Costume: Emergency Shields.

Read full description

Associated Products

See All
See Less

Deals

Game description

Samurai Spaceman pack includes:

  • Superhero Costume: Buffs at Start of Combat

  • Samurai Costume: Buffs when you Defeat an Enemy

  • Spaceman Costume: Emergency Shields

Game info
  • 72

  • 0

  • Rating
Publisher:
Ubisoft
Developer:
Obsidian Entertainment
Genres:
Action
Source:
Ubisoft
Released:
Tuesday, April 1, 2014
Modes:
Languages:
English, French, German, Italian, Spanish
Headset:
{{vrNames}}
Customer notes

This DLC requires the South Park: The Stick of Truth base game.

Minimum Requirements
  • OPERATING SYSTEM: Windows XP SP3, Vista SP2, Windows 7® SP1, Windows 8 (both 32/64bit versions)
  • PROCESSOR: Intel Core®2Duo E2180 @ 2.0 GHz or AMD Athlon™ X2 3800+ @ 2.0 GHz
  • RAM: 2 GB (Recommended 4GB or more)
  • VIDEO CARD: nVidia GeForce® 7900GT or AMD Radeon™ 2900 - See supported List*
  • DIRECT X®: DirectX® June 2010
  • SOUND: DirectX® Compatible Sound Card with latest drivers
  • HARD DISK: 4 GB
  • PERIPHERALS: Windows-compatible keyboard and mouse required, optional controller

*SUPPORTED VIDEO CARDS AT TIME OF RELEASE: AMD Radeon™ 2600 or better, HD3000, HD4000, HD5000, HD6000, HD7000, R7 and R9 series nVidia: GeForce 8800GT or better, GeForce 9, GT200, GT400, GT500, GT600, GT700 series

Note: Laptop versions of these cards may work but are NOT offi cially supported. Latest GeForce drivers tested: 320.49 for all series Latest Radeon drivers tested: 13.1 for Radeon HD2600, 13.9 for Radeon HD5000 and above.

Recommended Requirements
  • OPERATING SYSTEM: Windows XP SP3, Vista SP2, Windows 7® SP1, Windows 8 (both 32/64bit versions)
  • PROCESSOR: Intel Core®2Duo E4400 @ 2.0 GHz or better / AMD Athlon™ X2 4400+ @ 2.3 GHz or better
  • VIDEO CARD: nVidia GeForce® 8800GT or AMD Radeon™ HD3870) / 512MB VRAM with Shader Model 3.0 or higher - See supported List*
  • DIRECT X®: DirectX® June 2010
  • SOUND: DirectX® Compatible Sound Card with latest drivers
  • HARD DISK: 4 GB
  • PERIPHERALS: Windows-compatible keyboard and mouse required, optional controller

*SUPPORTED VIDEO CARDS AT TIME OF RELEASE: AMD Radeon™ 2600 or better, HD3000, HD4000, HD5000, HD6000, HD7000, R7 and R9 series nVidia: GeForce 8800GT or better, GeForce 9, GT200, GT400, GT500, GT600, GT700 series

Note: Laptop versions of these cards may work but are NOT offi cially supported. Latest GeForce drivers tested: 320.49 for all series Latest Radeon drivers tested: 13.1 for Radeon HD2600, 13.9 for Radeon HD5000 and above.

Legal

More like this

User score

72
Overall score based on 2 reviews Leave a review

Reviews for South Park: The Stick of Truth - Samurai Spaceman Pack

75
The Stick of Truth Review

The games South Park - The stick of truth is a very good game - The DLC (Downloadable Content) improves the game play by far. The game would not be the same without it as it provides nice skins. But I wouldn't purchase the DLC's (Downloadable content) unless they were on offer. The game South park - The stick of truth it self is a very good game, So if you are going to buy this pack, make sure you have this game installed or it will be of no use. DLC - 6/10 Game (South Park - Stick of Truth) - 9/10 Worth buying!

70
A nice DLC

Even if nothing special (only a bunch of skin), this DLC is nice. The new skins are good and nice to see, but are basically useless. Buy it only when on deal to spare some bucks.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away

Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required