{{ product.name }}

Tom Clancy's Rainbow Six Siege - Amethyst DLC

DRM

$2.99

$2.99

-{{product.discount}}%

WANTED
WANT IT

Community content

Tom Clancy's Rainbow Six Siege - Amethyst DLC

$2.99

$2.99

-{{product.discount}}%

$2.99

Associated Products

See All
See Less

Deals

Game description

Forge your weapons in Amethyst. This skin can be applied to any weapon in your loadout.
Game info
  • 81

  • Rating
Publisher:
Ubisoft
Developer:
Ubisoft Montreal
Genres:
Source:
Ubisoft
Released:
Tuesday, March 8, 2016
Modes:
Languages:
English, French, German, Italian, Spanish
Headset:
{{vrNames}}
Customer notes

Requires Tom Clancy's Rainbow Six Siege (base game) to use this DLC

Minimum Requirements

- OS: Windows 7, Windows 8.1, Windows 10 (64bit versions required)
- Processor: Intel Core i3 560 @ 3.3 GHz or AMD Phenom II X4 945 @ 3.0 GHz
- Memory: 6 GB RAM
- Graphics: NVIDIA GeForce GTX 460 or AMD Radeon HD 5870 (DirectX-11 compliant with 1GB of VRAM)
- Network: Broadband Internet connection

Recommended Requirements

- OS: Windows 7 SP1, Windows 8.1, Windows 10 (64bit versions required)
- Processor: Intel Core i5-2500K @ 3.3 GHz or better or AMD FX-8120 @ 3.1 Ghz or better
- Memory: 8 GB RAM
- Graphics: NVIDIA GeForce GTX 670 (or GTX 760 / GTX 960) or AMD Radeon HD 7970 (or R9 280x [2GB VRAM] / R9 380 / Fury X)
- Network: Broadband Internet connection

Legal

More like this

User score

81
Overall score based on 1 reviews Leave a review

Reviews for Tom Clancy's Rainbow Six Siege - Amethyst DLC

81
Cool looking skin

It's a bit of a lavender purple but it's nice, which kind of give it a swag feel to it, to activate the Amethyst skin after you buy the DLC right click Rainbow Six Siege in your library, View CD Keys, copy the Amethyst key, go in game, shop, redeem code, and paste the code.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away

Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required