{{ product.name }}

Train Simulator: Metro-North Kawasaki M8 EMU Add-On

DRM

$19.99

$17.99

-{{product.discount}}%

WANTED
WANT IT

Community content

Train Simulator: Metro-North Kawasaki M8 EMU Add-On

$19.99

$17.99

-{{product.discount}}%

$15.99

One of the newest electric multiple units for the Northeast Corridor comes to Train Simulator in Metro-North’s familiar bare metal and red livery.

Read full description

Associated Products

See All
See Less

Deals

Game description

One of the newest electric multiple units for the Northeast Corridor comes to Train Simulator in Metro-North’s familiar bare metal and red livery.

Built by Kawasaki at Lincoln, Nebraska for use on the New Haven Line, the M8 first entered service in March 2011 as a replacement to the current fleet of M2, M4 and M6 multiple units. Similar in body style to the M7, more than 300 units have been delivered to Metro-North so far, and feature multiple power pick-up – third rail and overhead pantograph – which can be changed by the engineer whilst on the move.

The two-car Kawasaki M8 has a top speed of 100mph (161km/h) and the model for Train Simulator features driving cabs and passenger views, switchable power modes and dynamic in-cab display screens showing instrument readouts and power pick-up mode.

The locomotive is also Quick Drive compatible, giving you the freedom to drive the Metro-North Kawasaki M8 on any Quick Drive enabled route for Train Simulator, such as those available through Steam. Also included are scenarios specifically for the NEC: New York-New Haven route (available separately and required to play these scenarios).


Scenarios:

Four scenarios for the NEC: New York-New Haven route:

  • Simple Controls Tutorial: M8 Simple Controls

  • Expert Controls Tutorial: M8 Expert Controls

  • Grand Central Bound

  • Stamford Local

More scenarios are available on Steam Workshop online and in-game. Train Simulator’s Steam Workshop scenarios are free and easy to download, adding many more hours of exciting gameplay. With scenarios being added daily, why don’t you check it out now!


Key Features:

  • Kawasaki M8 in Metro-North bare metal and red livery

  • In-cab signalling

  • Dynamic in-cab display screens

  • Switchable dual mode power pick-up

  • Quick Drive compatible

  • Scenarios for the NEC: New York-New Haven route

  • Download size: 128mb

Game info
  • 70

  • 0

  • Rating
Publisher:
Dovetail Games
Developer:
Dovetail Games
Genres:
Source:
Dovetail Games
Released:
Thursday, April 24, 2014
Modes:
Languages:
English
Headset:
{{vrNames}}
Customer notes

Train Simulator 2015 is required to play this DLC.

Minimum Requirements
  • OS: Windows® Vista / 7 / 8
  • Processor: 2.8 GHz Core 2 Duo (3.2 GHz Core 2 Duo recommended), AMD Athlon MP
  • (multiprocessor variant or comparable processors)
  • Memory: 2 GB RAM
  • Graphics: 512 MB with Pixel Shader 3.0 (AGP PCIe only)
  • DirectX: Version 9.0
  • Network: Broadband Internet connection
Recommended Requirements
  • Graphics:Laptop versions of these chipsets may work but are not supported. Updates to your video and sound card drivers may be required
  • Additional:Quicktime Player is required for playing the videos
Legal

More like this

User score

70
Overall score based on 1 reviews Leave a review

Reviews for Train Simulator: Metro-North Kawasaki M8 EMU Add-On

70
A really good addition for the New York-New Haven route

The model detail for the M8 is great - couldn't really top it. Disappointingly the sound effects are a bit lacklustre, and other than the two 'tutorial' scenarios, the pack only contains two scenarios for you to play. This loco is a really good addition otherwise - very common place on the line. I recommend it, but it could be improved slightly. This unfortunately seems to be the way with some DTG addons at present.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away

Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required