{{ product.name }}

X-COM Complete Pack

DRM

$14.99

$14.99

-{{product.discount}}%

WANTED
WANT IT

Community content

X-COM Complete Pack

$14.99

$14.99

-{{product.discount}}%

This pack includes:

Read full description

Associated Products

See All
See Less

Deals

Game description

This pack includes:

  • X-COM: Apocalypse

  • X-COM: Enforcer

  • X-COM: Interceptor

  • X-COM: Terror From the Deep

  • X-COM: UFO Defense


  • X-COM: Apocalypse

    There's something evil in the city tonight... Earth has been ravaged by human excess, petty conflict and alien invasion. The world's population has been herded into huge cities, the first of which was Mega Primus.

  • X-COM: Enforcer

    X-COM: Earth's top-secret eXtraterrestrial COMbat unit. The Place: America - early 21st century. The Mission: Eradicate the extraterrestrials

  • X-COM: Interceptor

    They're back...only this time the heinous aliens are out to destroy Earth and rule the new frontier. As X-COM commander, it's your sole duty to protect humanity and the prized mining operations in outer space. You must strategically equip your X-COM fighters, amass a formidable arsenal and then fulfill your mandate by going head-to-head with the devious element. The action is fast. And the opposing forces are wicked. But if you are smart, diligent and quick, you will prevail in a masterfully fought campaign to save our planet from perilous collapse.

  • X-COM: Terror From the Deep

    The war continues... X-COM: UFO Defense brought you to a galactic battlefield. X-COM: Terror from the Deep brings the alien terror into a totally new dimension. Seeking to take advantage of a weakened Earth, X-COM's deep space foes unexpectedly change strategy and launch a powerful second front against planet Earth.

  • X-COM: UFO Defense

    You are in control of X-COM: an organization formed by the world's governments to fight the ever-increasing alien menace.

Game info
  • 50

  • 0

  • Rating
Publisher:
2K Games
Developer:
MicroProse Software, Inc
Genres:
Source:
2K Games
Released:
Thursday, September 4, 2008
Modes:
Languages:
English, French, German, Spanish
Headset:
{{vrNames}}
Customer notes
Minimum Requirements

X-COM: Apocalypse

  • OS: Microsoft® 2000/XP/Vista®
  • Processor: Pentium 90MHz or better
  • Memory: 16Mb RAM
  • Graphics: Supported 32Mb Graphics Card
  • Sound Cards Supported: Sound Blaster and 100% compatibles, Microsoft Sound System, ESS Audio - Drive, ProAudio Spectrum, Ensoniq Soundscape and Gravis UltraSound
  • Hard Drive: 60 MB Hard Disk Space

X-COM: Enforcer

  • OS: Microsoft® 2000/XP/Vista®
  • Processor: Pentium II 233 MHz or higher with hardware acceleration, OR Pentium II 266 MHz or higher without hardware acceleration
  • Memory: 32 MB RAM
  • DirectX: 8.0 or higher
  • Sound Cards Supported: 1 MB Windows compatible sound card
  • Hard Disk Space: 500 MB

X-COM: Interceptor

  • OS: Microsoft® 2000/XP/Vista®
  • Processor: Pentium 166MHz or better
  • Memory: 16Mb RAM
  • Graphics: Must be capable of 16-bit graphics (High Color) and have a minimum of 2MB of video RAM
  • Hard Drive: 60 MB Hard Disk Space

X-COM: Terror From the Deep

  • OS: Windows XP*
  • Processor: 33MHz 386
  • Memory: 4MB RAM
  • Disk Space: 520KB Free
  • DirectX: 6.1 or later

X-COM: UFO Defense

  • OS: Microsoft® 2000/XP/Vista®
  • Processor: 80386 processor or better
  • Memory: 4Mb RAM
  • Sound Cards Supported: AdLib compatible cards, SoundBlaster compatible cards and the Roland LAPC-1.
Recommended Requirements
Legal

More like this

User score

50
Overall score based on 1 reviews Leave a review

Reviews for X-COM Complete Pack

50
A representation of how a great franchise declined

Taken as a whole, the X-COM Complete Pack is a very lacklustre bundle. While the original X-COM, and arguably, it's follow up, Terror From the Deep, still stands as a near timeless classic, the other games in the pack suffer from increasingly diminishing returns in terms of quality. X-COM itself remains as playable today as when it was originally released. The blend of strategic and tactical game play is very compelling. Being able to engage the aliens in direct combat is just as important as understanding the need to research new technology and co-ordinate logistics. The graphics are definitely dated by today's standards, but retain a bright, cartoon character to them. It can be a bit fussy at times, with the degree of micromanagement required, but for some, that's part of the appeal. Terror from the Deep is basically the exact same game, but with an aquatic re-skin and blistering difficulty level. There's very little to differentiate it from the first game, but anyone looking for more will be satisfied. Apocalypse attempted to do something different, introducing the option for real-time gameplay. It succeeds on some levels, but disappoints on others. The sheer destructibility of the environments opens up new tactics, but the new strategic considerations aren't as deep as the original. Aesthetically, it lacks the cohesiveness and charm of the first two. An interesting footnote in the franchise's history, but far from being a must play. Interceptor and Enforcer are where the franchise really falls apart, and bring down the quality of the entire bundle. Both make an attempt to co-opt the X-COM name for a more action oriented game, and both fail. Even when they were released, they were considerably more shallow than other games in their genres, and are worth little more than as curiosities today. Other than a few token inclusions, they are devoid of the character of the original games and completely miss what made them so captivating. By itself, the original X-COM is almost entirely worth the price tag. Aside from that, however, most of the games here serve more as relics of an earlier period in gaming than as worthwhile games in their own right.

Load More
Load More
Thanks for review.

All reviews are moderated and may not appear on the site staight away

Thank you for your patience whilst we complete this process.

Write a review
All fields are mandatory
This field is required
This field is required